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Logistics Tablet Maintenance Inspections

Logistics Tablet Maintenance Inspections

The Inspections view displays current inspections and individual inspection items for the currently selected job. Using this view, new inspections and inspection items can be created.

Inspections and inspection items can only be created if a corresponding maintenance request is selected from the Select an Open Maintenance Request drop-down list.

When inspections are created by the maintenance inspector, they initially have a status of draft. This allows for multiple inspection items to be added whilst the maintenance inspector is on-site. At the completion of the inspection, the inspection is finalised, allowing the maintenance inspector to create a maintenance inspection document, in PDF format, to be signed and, if required, emailed to the client. Signing the inspection adds the current date against the inspection.

Inspection List

Column

Description

#

Automatically generated inspection number.

Start

Date the inspection was started.

Prepared

Date the inspection was prepared.

Signed

Date the inspection was signed by the maintenance inspector.

Status

Inspection status.

Type

Type of inspection.

Category

Inspection category.

Inspector

Name of the maintenance inspector.

Indicates the presence of notes, visible to the client, relating to the inspection.

Indicates the presence of internal notes, not visible to the client, relating to the inspection.

Inspection Items List

Column

Description

#

Automatically generated inspection item number.

Location

Location of the inspection item.

Zone

Zone associated with inspection item.

Position

Position of the inspection item in the zone.

Item

Name of the defective item.

Defect

Specific imperfection relating to the inspection item.

Responsible

Entity responsible for causing the imperfection.

Rectification

Entity responsible for fixing the imperfection.

Indicates the presence of backcharge.

Indicates the presence of notes relating to the inspection item.

Indicates the presence of an image relating to the inspection item.

Indicates whether the inspection item has been allocated to a maintenance request item.

Procedures

Creating An Inspection

An inspection is typically created when a maintenance inspector arrives on-site to perform an inspection of a house. An inspection may be required as a standard warranty inspection or due to a specific claim placed by the client.

  1. From the Select an Open Maintenance Request drop-down list, select an open maintenance request.
  2. Tap the Inspection list.
  3. From the Action sidebar, tap New. The Inspection dialog will be displayed.
  4. Enter the details.
  5. Tap OK. The dialog will close and a new inspection will be created. The Inspections list will be updated and the status of the inspection will be set to Draft (Tablet).

Creating An Inspection Item

Inspection items are the specific items identified by the maintenance inspector that require further investigation or repair. Before an inspection item can be created, ensure that a new inspection has been created. Multiple inspection items can be created for a single inspection.

Example

Let's say that a broken toilet bowl has resulted in damage to the surrounding skirting boards in the toilet. In this instance, a second inspection item would be created for the damage and replacement of the skirting boards.


  1. From the Select an Open Maintenance Request drop-down list, select an open maintenance request.
  2. From the Inspection list, select an inspection.
  3. Tap the Inspection Item list.
  4. From the Action sidebar, tap New. The Inspection Item dialog will be displayed.
  5. Enter the details.
  6. Tap OK. The dialog will close and a new inspection item will be created.

Finalising An Inspection

When a maintenance inspector has completed an inspection, the inspection needs to be finalised. Finalised inspections are then signed off by the client.

  1. From the Inspection list, select an inspection.
  2. Tap Finalise. The corresponding Status cell will change to Final (Tablet).

Creating A Maintenance Inspection File

Once an inspection has been finalised, the maintenance inspector then creates an electronic PDF document, indicating the tasks performed (such as creating inspection items). This document is automatically saved to Job Files. Once saved, the maintenance inspector and client must physically sign and date the electronic PDF document by opening the file and signing the document using the Tablet PC pen.

  1. From the Inspection list, select an inspection.
  2. Tap Create File. The Maintenance Inspection PDF file will created and copied to Job Files.

Signing An Inspection

When the maintenance inspection PDF has been created and signed via the Tablet PC pen, the inspection needs to be signed off.

  1. From the Inspection list, select an inspection.
  2. Tap Sign. The corresponding Signed cell will update with today's date.

Emailing An Inspection

Completed inspection items, viewable on the maintenance inspection PDF, can be emailed to clients and to required office staff.

  1. From the Inspection list, select an inspection.
  2. Tap Email. An email message containing the maintenance inspection PDF document will be displayed in the user's default email program.
  3. Send the email, as required.

Assigning An Inspection Item

An inspection item is an item found by an inspector as part of their inspection. Once created, inspection items are then assigned to a maintenance request item.

Inspection items can be viewed by office staff on the Maintenance Requests screen of Framework ECM.

  1. From the Select an Open Maintenance Request drop-down list, select an open maintenance request.
  2. From the Inspection list, select an inspection.
  3. Tap the Inspection Item list and select an inspection item to be assigned to a maintenance request item.
  4. From the Action sidebar, tap Assign. The Assign Maintenance Inspection Item dialog will be displayed.
  5. Assign an inspection item to a maintenance request item.
  6. Tap Close. The dialog will close and an inspection item will be assigned to the selected maintenance request item.

Inspection Dialog

This dialog is used to create a new on-site inspection.

General Group

Field

Description

Number

Automatically generated inspection number. This field is locked and cannot be edited.

Inspector

Staff member investigating the maintenance request. Click the Inspector popup button to select.

Type

Type of warranty. This field is locked and cannot be edited.

Category

Inspection category. Click the Category popup button to select.

Example: Initial Inspection, Re-Inspection, Sign-Off Inspection.

Status

Inspection status. This field is locked and cannot be edited.

Client Contact

Client present during the inspection. Click the Client Contact popup button to select.

Work Flow Group

Manual forecast and actual dates can be entered, as required.

Field

Description

Start Date

Start date for the inspection.

Start Time

Start time for the inspection.

Complete Date

Date the inspection was completed.

Complete Time

Time the inspection was completed.

Prepared

Date the maintenance inspection PDF was prepared.

Signed

Date the maintenance inspection PDF was signed.

Notes Group

Field

Description

Add Std. Notes

Pre-defined standard notes. When selected, the standard note is added to the Notes Shownfield. Tap the Add Std. Notes drop-down list to select.

Notes Shown

Free text area for notes regarding the inspection. These notes are available to the client.

Add Std. Notes

Pre-defined standard notes. When selected, the standard note is added to the Notes Internalfield. Tap the Add Std. Notes drop-down list to select.

Notes Internal

Free text area for notes regarding the inspection. These notes are for internal use only and will not be visible to the client.

Inspection Item Dialog - Simple View

This dialog is used to create a new inspection item.

The Advanced view contains more inspection item selections than the Simple view.


Inspection Item Dialog Sidebar

The Inspection Item dialog sidebar contains the following options: 

Action Group

Action

Description

Add

Add an inspection item to the Inspection Items list. The highlighted inspection is copied and the# column is updated.

Update

Update the currently selected inspection item. Use this to modify a currently selected inspection item.

Delete

Delete the currently selected inspection item.

Default

Reset the Select and Enter Item Details group to the default selections.

Close

Close the dialog.

Image Group

Image

Description

Capture

Tap to capture an image.

Clear

Tap to clear the image.

View

Tap to view the image.

View Group

Image

Description

Simple

Tap to open the simple view

Advanced

Tap to open the Advanced view

Lists

Select And Enter Item Details Group

Field

Description

Image

Photograph of the imperfection. Images can be captured, deleted, or viewed.

Location

Location of the inspection item.

Example: Internal, External.

Zone

Zone associated with inspection item.

Example: Balcony, Bathroom 1 , Bedroom 2, etc.

Position

Location in the zone of the inspection item.

Example: Rear, Front, Left, Right, Ceiling, Floor.

Add std. Notes

Pre-defined standard notes. Tap the Add Std. Notes drop-down list to select.

Inspection Items List

Field

Description

#

Internally generated inspection item number.

Location

Location of the inspection item.

Zone

Zone associated with inspection item.

Position

Location in the zone of the inspection item.

Item

Name of the defective item.

Defect

Specific imperfection relating to the inspection item.

Cause

Cause of the imperfection.

Responsible

Entity responsible for causing the imperfection.

Rectification

Entity responsible for fixing the imperfection.

Indicates that the responsible entity will be backcharged for the inspection item.

Indicates the presence of notes relating to the inspection item.

Indicates the presence of an image relating to the inspection item.

Indicates whether the inspection item has been allocated to a maintenance request item.

Buttons

Button

Description


Tap to add an inspection item.

The options selected in the Select and Enter Item Details group will be added to the Inspection Items list.

Procedures

Adding Multiple Inspection Items

Example

Let's say that a broken toilet bowl has resulted in damage to the surrounding skirting boards. In this instance, a second inspection item would be created for the damage and replacement of the skirting boards.


On the Inspection Item dialog:

  1. From the Inspection Items list, select an item to be copied.
  2. Click Add. A copy of the inspection item will be created, updating the # column.
  3. Select the new inspection item and update the Select and Enter Item Details group.
  4. Once all of the information has been updated, click Update.
  5. When finished, tap Close.

Inspection Item Dialog - Advanced View

This dialog is used to create a new inspection item.

The Advanced view contains more inspection item selections than the Simple view.


Image Group

Image

Description

Capture

Tap to capture an image.

Clear

Tap to clear the image.

View

Tap to view the image.

View Group

Image

Description

Simple

Tap to open the simple view

Advanced

Tap to open the Advanced view

Lists

Select And Enter Item Details Group

Field

Description

Location

Location of the inspection item.

Example: Internal, External.

Zone

Zone associated with inspection item.

Example: Balcony, Bathroom 1 , Bedroom 2, etc.

Position

Location in the zone of the inspection item.

Example: Rear, Front, Left, Right, Ceiling, Floor.

Item

Name of the defective item.

Example: Robe, Toilet, Render, Sink, etc.

Defect

Specific imperfection relating to the inspection item.

Example: Warped, Cracked, Not Level, etc.

Cause

Cause of the imperfection.

Example: Major Defect, Supplier, Trade, etc.

Backcharge

Backcharge recommendation against the entity responsible for causing the imperfection.

Responsible

Entity responsible for causing the imperfection.

Rectification

Entity responsible for fixing the imperfection.

Image

Photograph of the imperfection. Images can be captured, deleted, or viewed.

Add std. Notes

Pre-defined standard notes. Tap the Add Std. Notes drop-down list to select.

Inspection Items List

Field

Description

#

Internally generated inspection item number.

Location

Location of the inspection item.

Zone

Zone associated with inspection item.

Position

Location in the zone of the inspection item.

Item

Name of the defective item.

Defect

Specific imperfection relating to the inspection item.

Cause

Cause of the imperfection.

Responsible

Entity responsible for causing the imperfection.

Rectification

Entity responsible for fixing the imperfection.

Indicates that the responsible entity will be backcharged for the inspection item.

Indicates the presence of notes relating to the inspection item.

Indicates the presence of an image relating to the inspection item.

Indicates whether the inspection item has been allocated to a maintenance request item.

Buttons

Button

Description

Tap to add an inspection item.

The options selected in the Select and Enter Item Details group will be added to the Inspection Items list.

Procedures

Adding Multiple Inspection Items

Example

Let's say that a broken toilet bowl has resulted in damage to the surrounding skirting boards. In this instance, a second inspection item would be created for the damage and replacement of the skirting boards.

On the Inspection Item dialog:

  1. From the Inspection Items list, select an item to be copied.
  2. Click Add. A copy of the inspection item will be created, updating the # column.
  3. Select the new inspection item and update the Select and Enter Item Details group.
  4. Once all of the information has been updated, click Update.
  5. When finished, tap Close.